阿里云服务器报“wordpress IP验证不当”漏洞的解决办法

今天登陆阿里云服务器控制台,提示网站存在漏洞,等级为“需尽快修复”。对于我这种强迫症的人来说,这样的提醒当然是越早消灭掉越好。下面是阿里给出的“wordpress IP验证不当漏洞”说明:

wordpress IP验证不当漏洞

需尽快修复

基本信息标题:wordpress IP验证不当漏洞披露时间: 1970-01-01 08:00:00简介:wordpress /wp-includes/http.php文件中的wp_http_validate_url函数对输入IP验证不当,导致黑客可构造类似于012.10.10.10这样的畸形IP绕过验证,进行SSRF。解决方案:方案一:使用云盾自研补丁进行一键修复;方案二:更新该软件到官方最新版本或寻求该软件提供商的帮助。【注意:该补丁为云盾自研代码修复方案,云盾会根据您当前代码是否符合云盾自研的修复模式进行检测,如果您自行采取了底层/框架统一修复、或者使用了其他的修复方案,可能会导致您虽然已经修复了该漏洞,云盾依然报告存在漏洞,遇到该情况可选择忽略该漏洞提示】

如何修复

1、在路径:/data/wwwroot/www.domain.com/wp-includes/http.php找到http.php文件,用Notepad++打开(修改之前记得先备份http.php原文件),大概在533行(不同的WordPress版本可能行数不同,你可以查找关键词进行查找):

2、在http.php文件的549行:

漏洞修复完成

修改完以上内容,然后再到阿里云盾控制台重新验证一下漏洞,就会发现漏洞已经不存在了。

漏洞修复完成


总计 0 评论

发表评论

作为 登录 | 登出 »

联系电话

18321263196

交换链接

互相学习

服务咨询

我的微信