LNMP升级PHP7.4各种问题解决

我的blog使用的是lnmp1.5版本的,运行upgrade.sh进行php版本升级,在输入版本7.4.5之后发现没有任何反应,于是我查看该脚本,发现lnmp1.5对php升级的支持最高是7.2,而lnmp1.6版本的最高支持是php7.3,如果需要升级到php7.4需要lnmp1.7版本,不过官方目前1.7还是beta版,但是我们同样可以升级,因为升级php调用的是include下的upgrade_php.sh,因此我下载1.7版本下来,用最新的upgrade_php.sh进行替换,然后再次升级,报错如下

  1. /bin/lnmp /etc/init.d/php-fpm no such file or directory

你如果去网上搜索答案,一大片装载的文章告诉你重新创建/etc/init.d/php-fpm文件,但是这里不行,看lnmp错误日志,提示错误如下

  1. checking for libzip >= 0.11... no
  2. configure: error: Package requirements (libzip >= 0.11) were not met:
  3. Requested 'libzip >= 0.11' but version of libzip is 0.10.1

很明显是libzip版本过低,需要升级到0.11以上的版本,自己编译过程如下

  1. # wget https://libzip.org/download/libzip-1.5.2.tar.gz
  2. # tar zxvf libzip-1.5.2.tar.gz
  3. # yum install cmake3 -y
  4. # mkdir build && cd build && cmake3 .. && make && make install

完成libzip编译并且make install之后再次升级php7.4,发现仍然报错libzip版本过低,这时候查看一下libzip.so的路径,比如我的在/usr/local/lib64下,因此在lnmp目录环境下配置export PKG_CONFIG_PATH="/usr/local/lib64/pkgconfig/",让configure过程找到libzip,这样就可以完成php7.4的升级编译安装了。

扯了这么多最简单的办法来了。。。

  1. # yum install epel-release
  2. # yum install http://rpms.remirepo.net/enterprise/remi-release-7.rpm
  3. # yum search zip | grep php74
  4. php74-php-pecl-zip.x86_64 : Une extension de gestion des ZIP

安装上面的源,然后直接安装php74-php-pecl-zip.x86_64即可

相关来源:

https://www.11000011.com/?id=667

总计 0 评论

发表评论

作为 登录 | 登出 »

联系电话

18321263196

交换链接

互相学习

服务咨询

我的微信